Back to overview
Downtime
Some services are down
Sep 13 at 01:00am WEST
Resolved
Sep 13 at 01:00am WEST
IMAP imap.clix.pt:993, SMTP mail.clix.pt:465, and POP3 pop.clix.pt:995 went down.
Affected services
Resolved
Sep 13 at 01:00am WEST
IMAP imap.clix.pt:993, SMTP mail.clix.pt:465, and POP3 pop.clix.pt:995 went down.
Affected services